Fedora 8 → Fedora 9 アップグレード

Fedora 8 → 9 アップグレード

現在はFedora10 が既にリリースされていますが、
とあるちょっと重要な管理サーバが未だFedora 8 であったため、アップグレードをおこないました。

2009年2月15日 現在で作業しました。

作業は既に Fedora10 が出ていたり、Fedora 8 の update によっての依存関係で結構苦労しました。

その時の手順等をの記事にします。

ちなみにアップグレードにはリスクが多いため、最悪、再起動しなくなるおそれもありますので、
テスト等と確実におこなってください。

1.fedora-release と fedora-release-notes のダウンロード

# wget http://ftp.kddilabs.jp/Linux/packages/fedora/releases/9/Fedora/x86_64/os/Packages/fedora-release-9-2.noarch.rpm
# wget http://ftp.kddilabs.jp/Linux/packages/fedora/releases/9/Fedora/x86_64/os/Packages/fedora-release-notes-9.0.0-1.noarch.rpm

2.fedora-release と fedora-release-notes のインストール

# rpm -Uvh fedora-release-9-2.noarch.rpm fedora-release-notes-9.0.0-1.noarch.rpm

3.アップデート作業

# yum clean all
# yum upgrade
python-2.5.1-26.fc8.2.x86_64 from installed has depsolving problems
–> Missing Dependency: libssl.so.6()(64bit) is needed by package python-2.5.1-26.fc8.2.x86_64 (installed)
python-2.5.1-26.fc8.2.x86_64 from installed has depsolving problems
–> Missing Dependency: libcrypto.so.6()(64bit) is needed by package python-2.5.1-26.fc8.2.x86_64 (installed)
gnupg2-2.0.9-2.fc8.x86_64 from installed has depsolving problems
–> Missing Dependency: libldap-2.3.so.0()(64bit) is needed by package gnupg2-2.0.9-2.fc8.x86_64 (installed)
Error: Missing Dependency: libcrypto.so.6()(64bit) is needed by package python-2.5.1-26.fc8.2.x86_64 (installed)
Error: Missing Dependency: libldap-2.3.so.0()(64bit) is needed by package gnupg2-2.0.9-2.fc8.x86_64 (installed)
Error: Missing Dependency: libssl.so.6()(64bit) is needed by package python-2.5.1-26.fc8.2.x86_64 (installed)

エラーが発生して正常にアップグレードができませんでした。
原因はpython-2.5.1-26.fc8.2.x86_64 の依存関係です。
ネットで調べたところ、エラーが発生した場合はエラーのモジュールを一度アンインストールしろと書いてあったですが
python を消すと yum も依存関係で削除されてしまいます。
しかし、このままでは進まないため仕方がないので一度削除しました。

# yum remove python

すると、予定通り yum もアンインストールされてしまいました。
そこで、調査の結果、このエラーはFedora 8 と Fedora 9 の依存関係の違いであることがわかり
DVDより再度RPMにてインストールすることにしました。

# mount /dev/dvd /mnt
# cd /mnt/Packages

インストール時に既に最新版がインストールされていますと警告が出るため、
ダウングレードと明記します。

# rpm -Uvh –oldpackage \
yum-3.2.7-1.fc8.noarch.rpm \
yum-metadata-parser-1.1.2-1.fc8.x86_64.rpm \
python-2.5.1-15.fc8.x86_64.rpm \
python-iniparse-0.2.2-1.fc8.noarch.rpm \
rpm-python-4.4.2.2-3.fc8.x86_64.rpm \
python-urlgrabber-3.0.0-3.fc8.noarch.rpm \
python-libs-2.5.1-15.fc8.x86_64.rpm \
rpm-libs-4.4.2.2-3.fc8.x86_64.rpm \

再度、アップグレードに挑戦

# yum clean all
# yum upgrade
–> Finished Dependency Resolution
Error: Missing Dependency: libldap-2.3.so.0()(64bit) is needed by package gnupg2

再びエラーが発生しました。

# yum remove gnupg2

そんなに影響がないため、アンインストール。また、依存関係もなし。

# yum clean all
# yum upgrade
Transaction Check Error:
package audit-libs-1.7.4-1.fc8 (which is newer than audit-libs-1.7.2-6.fc9) is already installed
Error Summary
————-

途中で再びエラー

package audit-libs 既にインストールされています。だって。
よく見ると Fedora 9 の方がバージョンが古いですね。
よってダウングレード

# rpm -Uvh –oldpackage http://ftp.iij.ad.jp/pub/linux/fedora/releases/9/Fedora/x86_64/os/Packages/audit-libs-1.7.2-6.fc9.x86_64.rpm

再度アップグレード

# yum upgrade

ついに、正常に終了しました。
やっと再起動です。

# sync
# reboot

再起動後に再度 yum でアップデートをおこないましたがなんとまたまた依存関係でエラー・・・

# yum update
python-2.5.1-26.fc8.2.x86_64 from updates-newkey has depsolving problems
–> Missing Dependency: libssl.so.6()(64bit) is needed by package python-2.5.1-26.fc8.2.x86_64 (updates-newkey)
python-2.5.1-26.fc8.2.x86_64 from updates-newkey has depsolving problems
–> Missing Dependency: libcrypto.so.6()(64bit) is needed by package python-2.5.1-26.fc8.2.x86_64 (updates-newkey)
gnupg2-2.0.9-2.fc8.x86_64 from updates-newkey has depsolving problems
–> Missing Dependency: libldap-2.3.so.0()(64bit) is needed by package gnupg2-2.0.9-2.fc8.x86_64 (updates-newkey)
Error: Missing Dependency: libcrypto.so.6()(64bit) is needed by package python-2.5.1-26.fc8.2.x86_64 (updates-newkey)
Error: Missing Dependency: libldap-2.3.so.0()(64bit) is needed by package gnupg2-2.0.9-2.fc8.x86_64 (updates-newkey)
Error: Missing Dependency: libssl.so.6()(64bit) is needed by package python-2.5.1-26.fc8.2.x86_64 (updates-newkey)

テスト環境で調査の結果、そのまま Fedora 10 へアップグレードをしても問題なかったため、
Fedora 10 へアップグレードをすることにしました。

次回、Fedora 10 へアップグレード

以上

フォローする